Forums

Help test next version of MonoDevelop/Xamarin Studio add-in

General discussion about Cobra. Releases and general news will also be posted here.
Feel free to ask questions or just say "Hello".

Re: Help test next version of MonoDevelop/Xamarin Studio add

Postby DelphiGuy » Sat Nov 23, 2013 2:25 pm

with switch corrected to "-x86", install went just fine, except for same warning i got from 64-bit install.
DelphiGuy
 
Posts: 116

Re: Help test next version of MonoDevelop/Xamarin Studio add

Postby nerdzero » Sat Nov 23, 2013 11:51 pm

Hmm, that's weird. In your output it seemed to be trying to use MSBuild from .NET 2.0, and the Platform seemed to be the path to the targets file.

C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Microsoft.Common.targets(490,9)
: error : The OutputPath property is not set for this project. Please check to
make sure that you have specified a valid Configuration/Platform combination.
Configuration='Debug' Platform='' [C:\temp\cobra-workspace\Source\Cobra.MSBui
ld\Targets\Cobra.targets]

I'll have to dig into this a bit more.
nerdzero
 
Posts: 286
Location: Chicago, IL

Re: Help test next version of MonoDevelop/Xamarin Studio add

Postby nerdzero » Sun Nov 24, 2013 9:45 am

Okay, I am able to reproduce this by explicitly specifying values for the "Configuration" or "Platform" properties from the command line when trying to run that build target. Even if I explicitly set the values to blank, then I get the message.

I am not sure why it tries to import 'Microsoft.Common.targets' from .NET 2.0, but looking at the file I can see the conditions that will trigger this error message. I will try to fix it.
nerdzero
 
Posts: 286
Location: Chicago, IL

Re: Help test next version of MonoDevelop/Xamarin Studio add

Postby nerdzero » Sun Nov 24, 2013 10:00 am

I was using single quotes instead of double-quotes when trying blank values. So, this seems to not trigger the problem for me:
Code: Select all
C:\Windows\Microsoft.NET\Framework64\v4.0.30319\msbuild.exe /property:Configuration="";Platform="" /target:DisplayMSBuildExtensionsPath .\Cobra.MSBuild\Targets\Cobra.targets

DelphiGuy, can you try that when you get a chance and post the output?
nerdzero
 
Posts: 286
Location: Chicago, IL

Re: Help test next version of MonoDevelop/Xamarin Studio add

Postby DelphiGuy » Sun Nov 24, 2013 11:06 am

nerdzero wrote:DelphiGuy, can you try that when you get a chance and post the output?


Code: Select all
C:\temp\cobra-workspace\Source>C:\Windows\Microsoft.NET\Framework64\v4.0.30319\m
sbuild.exe /property:Configuration="";Platform="" /target:DisplayMSBuildExtensio
nsPath .\Cobra.MSBuild\Targets\Cobra.targets
Microsoft (R) Build Engine version 4.0.30319.17929
[Microsoft .NET Framework, version 4.0.30319.18052]
Copyright (C) Microsoft Corporation. All rights reserved.

Build started 11/24/2013 1:05:54 PM.
Project "C:\temp\cobra-workspace\Source\Cobra.MSBuild\Targets\Cobra.targets" on
 node 1 (DisplayMSBuildExtensionsPath target(s)).
DisplayMSBuildExtensionsPath:
  C:\Program Files (x86)\MSBuild
Done Building Project "C:\temp\cobra-workspace\Source\Cobra.MSBuild\Targets\Cob
ra.targets" (DisplayMSBuildExtensionsPath target(s)).


Build succeeded.
    0 Warning(s)
    0 Error(s)

Time Elapsed 00:00:00.10

C:\temp\cobra-workspace\Source>
DelphiGuy
 
Posts: 116

Re: Help test next version of MonoDevelop/Xamarin Studio add

Postby nerdzero » Tue Nov 26, 2013 11:11 am

The issue with not being able to find the MSBuild extensions path is now fixed in changeset 3058. Thanks for testing, DelphiGuy.
nerdzero
 
Posts: 286
Location: Chicago, IL

Re: Help test next version of MonoDevelop/Xamarin Studio add

Postby DelphiGuy » Wed Nov 27, 2013 2:04 am

yes, 3058 installs painlessly. thanks for the fix.
DelphiGuy
 
Posts: 116

Re: Help test next version of MonoDevelop/Xamarin Studio add

Postby kobi7 » Sun Dec 08, 2013 4:30 am

Hi!
I'm on linux lubuntu, trying to compile the MonoDevelop addin,
which fails.
I just did cobra install.cobra from the directory.
Here is the output

Do you wish to continue? [Y/N]
y
Running xbuild...
Running /usr/local/bin/cobra...
Failed!
std out:
Compilation failed - 3 errors, 0 warnings

std err:
TypeSystem/Parser.cobra(12): error: Cannot find type for "TypeSystemParser".
Tooltips/TooltipProvider.cobra(11): error: Cannot find "TooltipProvider" at component 3 of qualified type.
Completion/CobraParameterDataProvider.cobra(8): error: Cannot find type for "ParameterDataProvider".


The addin was not installed due to compilation errors.
Falun Dafa is Good.
Truth, Compassion, Forbearance is Good.
kobi7
 
Posts: 82
Location: Israel

Re: Help test next version of MonoDevelop/Xamarin Studio add

Postby nerdzero » Sun Dec 08, 2013 9:51 am

Which version of MonoDevelop do you have installed? Do you have multiple versions like both distribution provided and built from source?
nerdzero
 
Posts: 286
Location: Chicago, IL

Re: Help test next version of MonoDevelop/Xamarin Studio add

Postby kobi7 » Tue Dec 10, 2013 7:00 am

sorry, my bad. I only skimmed the readme.
I have now ran the compilation for monodevelop source from github, and the addin worked immediately.
Will soon spend some time with this.
Thank you, it feels good to have an IDE at hand. :-)
Falun Dafa is Good.
Truth, Compassion, Forbearance is Good.
kobi7
 
Posts: 82
Location: Israel

PreviousNext

Return to Discussion

Who is online

Users browsing this forum: No registered users and 4 guests

cron