Forums

Requirements not quite up to date

General discussion about Cobra. Releases and general news will also be posted here.
Feel free to ask questions or just say "Hello".

Requirements not quite up to date

Postby ptokremin » Wed Jul 09, 2014 10:51 am

Hello everyone,

and greetings from Germany. I've passed Cobra a few times and finally decided to give it a try. I've already found some things I really like, and a few minor nuisance as well.
Not sure if this should be a ticket...

problem:
When I build from source (SVN:3116) the snapshot\cobra.exe crashes with the following exception (translated from german):
System.MissingMethodException: method not found: "Int32 System.Environment.get_CurrentManagedThreadId()"."

My build environment had only .NET 4.0 installed, but the property CurrentManagedThreadId is only available for .NET 4.5 or later. Upgrading to 4.5 solved the problem.

suggested solution:
Could it be possible to update the listed "Requirements" under "HowToInstallFromSource"?
"Microsoft .NET 2.0 and up" is a little misleading.


pre-build-environment (e.g. snapshot\cobra.exe):
Cobra svn:3079 (post 0.9.5) / 2013-12-23 on .NET CLR v4.0.30319 on Microsoft Windows NT 6.1.7601 Service Pack 1

post-build-environment:
Cobra svn:3116 (post 0.9.6) / 2014-07-09 on .NET CLR v4.0.30319 on Microsoft Windows NT 6.1.7601 Service Pack 1
ptokremin
 
Posts: 9
Location: Ruhrgebiet - Germany

Return to Discussion

Who is online

Users browsing this forum: Charles and 3 guests