dont you think it would be better to write
- Code: Select all
x = y as int
# instead of
x = y to int
i mean the variable doesnt change its type, just the value
'string as int' sounds valuerelated
'string to int' sounds variablerelated
also 'as' is already used for declaring a type and would naturally fit in
'to' would be free as keyword 'for 1 to 5' instead of 'for 1 .. 5' what looks bad btw
2:
i like the idea of 'post while' but i dont like that it is two words
did you thought about a single word like 'until'?
3:
often you code something like
- Code: Select all
x = foo()
if x > -1
bar()
did you thought about a way to bring the first two lines into one?
4:
what do you think about single line if
- Code: Select all
.quit if .keyHit
# instead of
if .keyHit, .quit