Forums

Server went down

General discussion about Cobra. Releases and general news will also be posted here.
Feel free to ask questions or just say "Hello".

Server went down

Postby Charles » Sat Apr 10, 2010 4:50 am

The cobra-language.com server began getting flaky in late March and unfortunately I did not have time to address it before it utterly crashed on April 9. Due to the hardware problems, backups began failing on March 28, so March 27 is the last snapshot I have of the files and database. On my local machine, I have the static files of the web site and multiple workspaces with the latest code, so I can easily restore those. However, forum posts and wiki edits from March 28 through April 9 are gone.

My new host provider has "image backups" which snapshot the entire drive on a daily basis (and on demand). Additionally, I'll be setting up tar+scp or rsync to an off-site server.

As of this moment, I have the static files and phpBB3 from March 27 up and running, although phpBB3 gives some warnings about timezone.

Also, I have set the DNS to point to the new IP address, but it will take a day or two for that to kick in for everyone.

As I continue to rebuild the server, I will reply in this thread with updates. If you have questions, let me know.
Charles
 
Posts: 2510
Location: Los Angeles, CA

Re: Server went down

Postby Charles » Sat Apr 10, 2010 5:19 am

I fixed the phpBB3 warning that was showing up on some pages.

I notice the phpBB3 URLs always have the "sid" in them, whereas before it would disappear (presumably into a cookie) after 1 or 2 page visits. That's a low priority, but if someone wants to help me out and research it, feel free.
Charles
 
Posts: 2510
Location: Los Angeles, CA

Re: Server went down

Postby Charles » Sat Apr 10, 2010 5:33 am

The static files have been copied. This covers the front page, news, releases/downloads, key documents, How To's, Samples and more.

Also, the domain name just started working for me, which is to say that it points to the new server.

There are undoubtedly some broken links to forum posts that I'll need to fix. Also, outstanding are Subversion and Trac.

But at least people can download the latest release and use the forums. I've been up all night and need some sleep. I'll continue later today.
Charles
 
Posts: 2510
Location: Los Angeles, CA

Re: Server went down

Postby Charles » Sat Apr 10, 2010 3:22 pm

I'm happy to report that Subversion has been restored. Also, by examining a local diff between a pre-existing workspace and a fresh checkout of the restored Subversion repository, I was able to recreate the missing checkins from the gap in the backup. So it's as if nothing ever happened. :-D

Sadly, that won't be the case for any wiki or ticket activity.

I have tested that "svn up" works on existing workspaces and that "svn co" works for new workspaces.

If you want a fresh workspace use:
Code: Select all
svn co http://cobra-language.com/svn/cobra/trunk cobra-workspace

You can browse the repository at http://cobra-language.com/svn/cobra/ like before.
Charles
 
Posts: 2510
Location: Los Angeles, CA

Re: Server went down

Postby Charles » Sun Apr 11, 2010 4:28 pm

I have set up the SMTP server and also made it so that the server is reachable through "www.", "ww." and "w." which redirect to the canonical http://cobra-language.com/

Hopefully, we'll get Trac up and running this week.
Charles
 
Posts: 2510
Location: Los Angeles, CA

Re: Server went down

Postby Charles » Tue Apr 13, 2010 12:17 am

Trac is now up and running so we have the wiki, tickets, timeline/history and repository browsing back online.

I still need to get phpBB3 working with cookies, but otherwise everything else should be up and running. If you know of any problems, please let me know here or at contact@cobralang.com!
Charles
 
Posts: 2510
Location: Los Angeles, CA

Re: Server went down

Postby hopscc » Tue Apr 13, 2010 3:59 am

I'll reenter the ticket and patch for cobra options file and
whatever I can remember of what I put in the forum discussion topic.
hopscc
 
Posts: 631
Location: New Plymouth, Taranaki, New Zealand

Re: Server went down

Postby Charles » Thu Apr 15, 2010 1:21 am

I have fixed the remaining phpBB3 problems and upgraded to the latest point release.

I have set up a nightly "tar cj + scp" backup on top of the disk image backups. With 2 forms of backup going to 2 different locations, we are in better shape for the future.

This completes the server rebuild. Thank you for your patience.
Charles
 
Posts: 2510
Location: Los Angeles, CA


Return to Discussion

Who is online

Users browsing this forum: No registered users and 4 guests

cron