Wiki

Ticket #194 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

Cobra compiler no longer compiles csharp only source.

Reported by: hopscc Owned by: Chuck
Priority: medium Milestone:
Component: Cobra Compiler Version: 0.8.0
Keywords: Cc:

Description

I just noticed that cobra no longer will compile a commandline composed only of sharp source files - it used to.
e.g. something like

cobra hello.cs
cobra app.cs support.cs class.cs

I find this convenient for testing csharp code or compiling tweaked cobra translations when I cant remember where the various frameworks squirrel the csharp compiler or what the compiler incantation is supposed to be.

It now fails compilation with
"error: Cannot find a "main" method."

Some investigation indicates that its failing the IdentifyMainPhase (reasonably enough) so I'd imagine its been a regression since that code was added.

I have a working fix, patch forthcoming.

Attachments

compile-cs.patch Download (4.1 KB) - added by hopscc 8 years ago.

Change History

Changed 8 years ago by hopscc

Changed 8 years ago by hopscc

  • status changed from new to assigned
  • owner changed from hops to Chuck

Patch, new Test + relnote.

Changed 8 years ago by Chuck

Fixed in changeset:2301.

I used the test cases in the patch, but otherwise implemented it differently. Since IdentifyMainPhase was the culprit, I put the entire fix there.

Changed 8 years ago by Chuck

  • status changed from assigned to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.