Wiki

Ticket #274 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Using 3rd Party Library 'Alsing.SyntaxBox' causes "COBRA INTERNAL ERROR"

Reported by: torial Owned by: Charles
Priority: major Milestone:
Component: Cobra Compiler Version: 0.8.0
Keywords: Internal Error 3rd Party Alsing Cc: charles

Description

When a line of code referencing a "SyntaxDocument?" is added to the code, the app will no longer compile, and instead the following error is reported:

error: COBRA INTERNAL ERROR / TargetException? / Non-static field requires a target.
Compilation failed - 1 error, 0 warnings
Not running due to errors above.

Attachments

bug.cobra Download (1.0 KB) - added by torial 7 years ago.
Most basic set of source code to reproduce the error.
Alsing.SyntaxBox.dll.7z Download (100.6 KB) - added by torial 7 years ago.
Referenced DLL (7z compressed)

Change History

Changed 7 years ago by torial

Most basic set of source code to reproduce the error.

Changed 7 years ago by torial

Referenced DLL (7z compressed)

Changed 7 years ago by torial

Also should add: this is w/ latest Cobra source code from about a week ago.

Changed 7 years ago by Charles

  • status changed from new to assigned
  • owner set to Charles

Using popular compression formats like .zip and .gz makes my life easier.

Changed 7 years ago by Charles

  • status changed from assigned to closed
  • resolution set to fixed

Fixed in changeset:2480

Thanks for the report.

Note: See TracTickets for help on using tickets.