Wiki

Ticket #303 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

static classes unsupported?

Reported by: kobi7 Owned by:
Priority: major Milestone:
Component: Cobra Compiler Version: 0.8.0
Keywords: Cc:

Description

if I set "is shared" on class, I get an error. (cannot declare instance members in a static class)

class ConsoleUtils is shared
	pass

the same is true for:

class ConsoleUtils is shared
    def x is shared
        pass

Is this by design?
(the benefit in setting a class static, is that it ensures all other members are static)

Thanks alot!

Change History

Changed 5 years ago by hopscc

Dup report
See ticket:179 (includes patch)

Changed 5 years ago by hopscc

  • status changed from new to closed
  • resolution set to duplicate
Note: See TracTickets for help on using tickets.