Wiki

Ticket #240 (closed defect: wontfix)

Opened 8 years ago

Last modified 8 years ago

-cin doesn't respect -kif

Reported by: Kurper Owned by:
Priority: minor Milestone:
Component: Cobra Compiler Version: 0.8.0
Keywords: Cc:

Description

Steps to reproduce:
1. Write some code.
2. Compile it.
3. Compile again with -cin -kif.

Expected: Since the intermediate files aren't there, it ought to generate them.

Result: Doesn't generate them, since -cin only looks for the .exe.

Change History

Changed 8 years ago by hopscc

By intent (and complexity of implementing otherwise) -cin Only determines recompilation on timestamp of exe vs sources,
there is no attempt to ascertain need on changed/new compiler options.

see  cobra -cin foo
and
 Compiler missing up to date checking
and
 compile-if-needed take into account a different -number?

Changed 8 years ago by Chuck

  • status changed from new to closed
  • resolution set to wontfix

Hops is correct. But I did expand the cobra -help on -compile-if-needed to help clarify its behavior. changeset:2421

Note: See TracTickets for help on using tickets.